Search results

  1. acthomp781

    New to me CUCV!

    Congratulations on the new truck!
  2. acthomp781

    Behr Paint Jobs- Show me your MV's

    That looks good. Where do you find something like that and if you don't ,mind, how much? Thanks.
  3. acthomp781

    Got a new m1009

    Thank you for posting pics. Just an hour ago I was looking for pictures of what the dash mounted radio equipment looked like. I am looking to get the radio/equipment for my M1009.
  4. acthomp781

    M1009 Little Red Riding Hood.

    Thank you.
  5. acthomp781

    M1009 Little Red Riding Hood.

    I do have a question. You stated you did all the underside painting. Do you do any kind of sand blasting? I have a 1986 M1009 that I would like to paint the underside but there is a fair amount of surface rust. Thank you for your time.
  6. acthomp781

    M1009 Little Red Riding Hood.

    WOW. That is one awesome M1009.
  7. acthomp781

    General antenna question

    I had the same questions as well. Thank you for the replies, pics and part numbers.
  8. acthomp781

    CUCV inner fender

    I replaced the inner fenders on my M1009. When I removed the old passenger side one, I noticed how accessible the fuel pump was, so I replaced it. I would suggest it would be a good time to replace your fuel pump if original. Just a suggestion.
  9. acthomp781

    Volt Gauge Mounting Bezel Needed

    I have one I can send you.
  10. acthomp781

    M1009 Exhust system

    Do you have the part numbers from Orielly's? I have been trying to find the parts for the exhaust for my M1009. Thank you.
  11. acthomp781

    My M1009

    That is a good looking truck. Thank you for posting pics and the updates.
  12. acthomp781

    Cucv back to stock glow plug controls

    Thanks for the update. It is good thing to get these old trucks running again.
  13. acthomp781

    Cucv back to stock glow plug controls

    I had the same issue with my 86 M1009 it had a push button and hard starting problems. Do you have a GP contoller card? If so you can look at getting the wiring back to stock, then you can use the TM's to diagnose your issue. I suggest printing out the wiring diagrams and see what has been done...
  14. acthomp781

    My M1009

    What does that 4 mean? I have a 4 on my right fender as well. The best I can tell my M1009 came from a National Guard unit in Indiana. The bumper number/marking is "38 38 MSB". I think the MSB may stand for Medical Support Battalion". Thanks.
  15. acthomp781

    What have you done to your CUCV today/lately - Part 2

    I replaced the core support bushings on my M1009. Not as daunting as I thought, not easy, but not horrible. I can think of much worse ways to spend a Saturday afternoon.
  16. acthomp781

    Crank, no start, white smoke.

    I got a fuel pump push rod from Kascar Real 4WD. They sell HMMWV parts, but the part number from the CUCV TM is the same as listed on this website. Quick shipping. I ordered 2 to have a spare. https://real4wd.com/store/catalog/search.aspx?keywords=fuel+pump+push+rod
  17. acthomp781

    "Another" Gen 1 Alternator Light Thread

    I had the same issue. The ground wire for Gen 1 was bad. I looked closely at the ends at the connectors and noticed "green stuff" where the wire strands were crimped in the connector. So I assumed this corrosion had gotten farther into the wire. I replaced with, if I remember right, an 8 gauge...
  18. acthomp781

    Laundry list for the m1009

    I had a similar issue with my M1009 brakes of a "crunching" sound the last few feet when coming to a stop. I removed the calipers and found a mouse skull between the rotor and backing plate:shock:, on one side, that was not the source of the sound, just a funny thing to find. I eventually...
  19. acthomp781

    CUCV Glow Plug Controller cards - Black Friday Sale

    I agree. Very fair price and fast shipping.
  20. acthomp781

    Gen 1 & 2 dash lights

    I just had a similar issue. My Gen 1 light would only come on at start up at times, not every time. I chased it down to the bulb socket brass "clips" that the bulb sits in the socket were slightly corroded. A few seconds with a small file and now the system works again.
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks