Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: MEP 804a Startup question

  1. #1
    Private
    Join Date
    Mar 2018
    Location
    Bridgewater, ma
    Posts
    10
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Default MEP 804a Startup question

    Hello all,
    I have a question about the startup switch positions and want to clear up what they do.

    There are 5 positions - Preheat, Off, Prime & Run Aux, Prime & Run, and Start

    1. Preheat - Preheats glow plugs, Is this required or for cold starts.

    2. Off - Off, No explanation needed

    3. Prime & Run Aux - Primes the fuel Pump for the Auxiliary fuel input.

    4. Prime & Run - Primes the pump for main tank

    5. Start - Starts the genset, after start turn back to the Aux Run or Run positions


    If any of that is not correct let me know... however the real question, when I turn it to position (3) Prime & Run Aux you can hear a pump turn on, however when I turn to Position (4) Prime & Run I do not hear a pump come on... the gen set starts fine so I assume the pump I hear is for the aux fuel input line?!

    Also, is there a best practice start-up manual? How long to pre-heat etc??

    Thanks guys




    Sent from my iPhone using Tapatalk

  2. #2
    Colonel
    Join Date
    Nov 2016
    Location
    South Hampton Roads, Virginia
    Posts
    344
    Thanks
    185
    Thanked 321 Times in 183 Posts

  3. The Following User Says Thank You to Zed254 For This Useful Post:

    Guyfang (12-02-2018)

  4. #3
    Private
    Join Date
    Mar 2018
    Location
    Bridgewater, ma
    Posts
    10
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Default

    Thanks, I already have all the TMs


    Sent from my iPhone using Tapatalk

  5. #4
    Colonel
    Join Date
    Nov 2016
    Location
    South Hampton Roads, Virginia
    Posts
    344
    Thanks
    185
    Thanked 321 Times in 183 Posts

    Default

    You might want to read ARMY TM 9-6115-643-10. It will answer your questions. I don't own an MEP-804A but reading the TM taught me that:

    You need to ground the unit.
    a. At temperatures below 40F (4C) turn MASTER SWITCH to PREHEAT for 30 seconds.
    b. Rotate MASTER SWITCH to START position.
    c. Hold MASTER SWITCH in START position until oil pressure reaches
    at least 25 psi (172kPa), voltage has increased to its approximate rated value, and engine has reached stable operating speed.
    d. Release MASTER SWITCH to PRIME AND RUN position.
    e . If operating with an auxiliary fuel source, rotate MASTER SWITCH to PRIME AND RUN AUX FUEL position.

    CAUTION
    Do not crank engine in excess of fifteen seconds. Allow starter to cool at least fifteen seconds between attempted starts.
    Failure to observe this caution could result in damage to the starter.

    Lots of good info in those manuals.

  6. The Following 3 Users Say Thank You to Zed254 For This Useful Post:

    Farmitall (12-01-2018), Fmeroney (12-01-2018), Guyfang (12-02-2018)

  7. #5
    Colonel
    Join Date
    Dec 2015
    Location
    Eubank, KY
    Posts
    369
    Thanks
    595
    Thanked 239 Times in 146 Posts

    Default

    A library is no good if nobody reads the books.

  8. The Following User Says Thank You to Farmitall For This Useful Post:

    Guyfang (12-02-2018)

  9. #6
    Sergeant Major
    Join Date
    Dec 2008
    Location
    Near Apex/NC
    Posts
    111
    Thanks
    11
    Thanked 68 Times in 34 Posts

    Default

    The MEP 804a has an Isuzu engine with a mechanical main fuel pump, thus when the switch is turned to main, silence until you go over to start. The 804b has the Yanmar turbo diesel which does have an electric main fuel pump and you will hear it running in main.

    Robert

  10. The Following 2 Users Say Thank You to robertsears1 For This Useful Post:

    Guyfang (12-02-2018), Zed254 (12-01-2018)

  11. #7
    Private
    Join Date
    Nov 2018
    Location
    charlotte, nc
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Default

    i have 2 mep 804a's, one works great but the other doesn't stay running unless I hold it to the start position even after oil pressure and hertz is at the proper level. W hen it cuts off the no fuel light comes on. What could be the problem there? And the fuel tank has over half a tank in it. And I noticed the aux fuel pump does not work on this one im having the problems with but that should be as simple as replacing the pump.

  12. #8
    4 Star General
    Join Date
    Mar 2014
    Location
    Efland, NC
    Posts
    1,710
    Thanks
    364
    Thanked 1,270 Times in 773 Posts

    Default

    Quote Originally Posted by 1973m35a2c View Post
    i have 2 mep 804a's, one works great but the other doesn't stay running unless I hold it to the start position even after oil pressure and hertz is at the proper level. W hen it cuts off the no fuel light comes on. What could be the problem there? And the fuel tank has over half a tank in it. And I noticed the aux fuel pump does not work on this one im having the problems with but that should be as simple as replacing the pump.
    Have you had the chance to check out the TMs? No fuel light is certainly an alarm that will prevent the unit from running.
    Chris Medico
    MEP-003a (sold), MEP-803a, MEP-802a, & MEP-831a

  13. The Following User Says Thank You to DieselAddict For This Useful Post:

    Guyfang (01-08-2019)

  14. #9
    2 Star Admiral Daybreak's Avatar
    Join Date
    Mar 2015
    Location
    Northern, Virginia
    Posts
    1,143
    Thanks
    161
    Thanked 1,368 Times in 623 Posts

    Default

    Howdy,

    Fuel level floats are stuck, dissolved, or broken.
    ~~Later Mike

  15. The Following User Says Thank You to Daybreak For This Useful Post:

    Guyfang (01-08-2019)

  16. #10
    4 Star General Guyfang's Avatar
    Join Date
    Dec 2015
    Location
    Burgkunstadt, Germany
    Posts
    4,906
    Thanks
    8,116
    Thanked 3,882 Times in 1,953 Posts

    Default

    Pull the float, check if its dirty, stuck, not adjusted properly or unanswerable.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •