Page 7 of 10 FirstFirst ... 3 4 5 6 7 8 9 10 LastLast
Results 61 to 70 of 92

Thread: M35a2 White Smoke

  1. #61
    4 Star General Floridianson's Avatar
    Join Date
    Dec 2006
    Location
    Interlachen Fl.
    Posts
    5,945
    Thanks
    2,694
    Thanked 3,107 Times in 1,583 Posts

    Default

    I was talking about him moaning.
    James

  2. The Following User Says Thank You to Floridianson For This Useful Post:

    frank8003 (02-08-2019)

  3. #62
    Sergeant WhoMe08721's Avatar
    Join Date
    Apr 2017
    Location
    Bayville/NJ
    Posts
    96
    Thanks
    0
    Thanked 64 Times in 26 Posts

    Default

    Hey guys,

    So today I finally got time to work on the M35a2. Removed all the injector nozzle and cleaned them. I also did a injector pop test on all of them. They all open at the pressure the (tm 9-2815-210-35) recommends and they did not drip or leak when high pressure was left on them. Then I checked the cylinder compression on all the cylinder with my custom Compression Tester I made. All cylinder where good on psi and held pressure. I am now stumped what to do. Tomorrow I was thinking to maybe check injector pump fuel adjustment screw, The cover is on it but there is no safety wire on the bolts. May be it loosen it self or it was not properly tighten. Any ideas. Thanks -Chris

  4. #63

  5. #64
    Corporal
    Join Date
    Jun 2018
    Location
    Las Cruces NM
    Posts
    44
    Thanks
    1
    Thanked 16 Times in 11 Posts

    Default

    Just my two cents, but my Dodge was blowing white smoke bad about 2 years ago and an old diesel mechanic told me to pour in a gallon of cheap ATF. I havenít had a problem since and the Cummins runs like a champ. Now I run a quart every 3rd or 4th tank.

  6. The Following User Says Thank You to Elk1111 For This Useful Post:

    frank8003 (02-08-2019)

  7. #65
    4 Star General frank8003's Avatar
    Join Date
    May 2012
    Location
    Ft. Lauderdale, Florida
    Posts
    3,730
    Thanks
    2,623
    Thanked 5,782 Times in 1,976 Posts

    Default

    You know that doing to many fixes at the same time will fix the problem but then You will never be able to post what the culprit was.
    The injectors................................
    I was here, had a good time.

  8. #66
    4 Star General Floridianson's Avatar
    Join Date
    Dec 2006
    Location
    Interlachen Fl.
    Posts
    5,945
    Thanks
    2,694
    Thanked 3,107 Times in 1,583 Posts

    Default

    Was there a reason you tried to measure the injector return line. Looks about right.
    James

  9. #67
    Sergeant WhoMe08721's Avatar
    Join Date
    Apr 2017
    Location
    Bayville/NJ
    Posts
    96
    Thanks
    0
    Thanked 64 Times in 26 Posts

    Default

    I didn't try to measure the injector return line

  10. #68
    Sergeant WhoMe08721's Avatar
    Join Date
    Apr 2017
    Location
    Bayville/NJ
    Posts
    96
    Thanks
    0
    Thanked 64 Times in 26 Posts

    Default

    Hey guys,

    So today I checked the injector pump fuel adjustment screw, and it look good. I also checked the Throttle linkage & the IP Timing they where good too. Finally I check the air breather filter & it was clean swapped it with a new one too. Now I am out of ideas what to check truck still not running right. Also is there away to check the Injection Pump Hydraulic Head (High Fuel Pressure Side) with the IP pump on the truck?

  11. #69
    dumpsterlandingfromorbit! gimpyrobb's Avatar
    Join Date
    Dec 2005
    Location
    Cincy Ohio
    Posts
    27,527
    Thanks
    2,429
    Thanked 8,769 Times in 4,572 Posts

    Default

    If the truck has idled a lot, it might stuck rings. Put as much weight in the bed as possible and drive it hard for an hour or two. Get it hot and drive it hard, the multi likes to work.

  12. #70
    Sergeant WhoMe08721's Avatar
    Join Date
    Apr 2017
    Location
    Bayville/NJ
    Posts
    96
    Thanks
    0
    Thanked 64 Times in 26 Posts

    Default

    I was thinking of that. But if it was stuck ring when I did the cylinder compression check it would have showed up. I would think

Page 7 of 10 FirstFirst ... 3 4 5 6 7 8 9 10 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •