Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20

Thread: continental multifuel

  1. #1
    Private
    Join Date
    Feb 2019
    Location
    McMinnville Tn
    Posts
    10
    Thanks
    0
    Thanked 6 Times in 2 Posts

    Default continental multifuel

    Hi this is the only place i thought i might could find help. I have a continental multifuel 465 out of a m35a2 that i put in an excavator has been in for several years. Anyways we used it recently ran great mo problem we shut it off and left it sitting for about a month and when we went to use it it will not start have changed fuel filters and bled system have checked to make sure the hh is pumping with a pencil stuck in it and turning the motor over it will start with either and run for a little while but white smoke boils out and will run for a bit then smother out does not make sense it was running great when it was shut off and now wont run and have verified the fuel shut off is working great any suggestions.

  2. #2
    4 Star General dmetalmiki's Avatar
    Join Date
    Aug 2006
    Location
    London England
    Posts
    4,206
    Thanks
    410
    Thanked 2,331 Times in 1,192 Posts

    Default

    Sounds like a head gasket has blown.
    Check compressions, and look in the radiator when it runs.
    Check the oil for contamination.
    DIAMOND T M20.
    M54A2 I.H. M62. wrecker
    M54A2 5 Ton (with Radio Body. ex praga command station)
    M45 530C fire truck
    M561 Gamma Goat
    1942 Ford Jeep (with underfloor tulsa winch)
    1945 Willys Jeep (with V8 flathead Engine) And now 'that' overdrive'..

  3. #3
    Private
    Join Date
    Feb 2019
    Location
    McMinnville Tn
    Posts
    10
    Thanks
    0
    Thanked 6 Times in 2 Posts

    Default

    Have not checked compression but have checked oil and have look in radiator while it is running

  4. #4
    dumpsterlandingfromorbit! gimpyrobb's Avatar
    Join Date
    Dec 2005
    Location
    Cincy Ohio
    Posts
    27,317
    Thanks
    2,391
    Thanked 8,477 Times in 4,443 Posts

    Default

    Check the fuel shutoff rod. It should move freely, but they often stick.

  5. #5
    Private
    Join Date
    Feb 2019
    Location
    McMinnville Tn
    Posts
    10
    Thanks
    0
    Thanked 6 Times in 2 Posts

    Default

    It moves freely

  6. #6
    dumpsterlandingfromorbit! gimpyrobb's Avatar
    Join Date
    Dec 2005
    Location
    Cincy Ohio
    Posts
    27,317
    Thanks
    2,391
    Thanked 8,477 Times in 4,443 Posts

    Default

    No need to remove it unless its siezed:

    https://www.steelsoldiers.com/showth...-Rod-on-the-IP

  7. #7
    Private
    Join Date
    Feb 2019
    Location
    McMinnville Tn
    Posts
    10
    Thanks
    0
    Thanked 6 Times in 2 Posts

    Default

    It moves freely and is clean on inside. By the way I do have another engine with a ip and hh would it be worth a shot putting a different hh on would no think head gasket with it just sitting

  8. #8
    dumpsterlandingfromorbit! gimpyrobb's Avatar
    Join Date
    Dec 2005
    Location
    Cincy Ohio
    Posts
    27,317
    Thanks
    2,391
    Thanked 8,477 Times in 4,443 Posts

    Default

    Id take the hyd head thats currently on there off. The plunger might move up and down, but if the button on the bottom fell off(which is common) you wont have the correct stroke to pump fuel.

    https://www.steelsoldiers.com/showth...Hydraulic-Head

  9. The Following User Says Thank You to gimpyrobb For This Useful Post:

    frank8003 (02-04-2019)

  10. #9
    Private
    Join Date
    Feb 2019
    Location
    McMinnville Tn
    Posts
    10
    Thanks
    0
    Thanked 6 Times in 2 Posts

    Default

    Would it run at all with the button off it will run for just a few minutes then will smother out

  11. #10
    Corporal
    Join Date
    Jun 2018
    Location
    Las Cruces NM
    Posts
    42
    Thanks
    1
    Thanked 16 Times in 11 Posts

    Default

    If your using either to start it itíll run for a bit on that but then shut off. My vote is itís the button also.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •