M1009 Burning smell from dash?

Status
Not open for further replies.

86k5

New member
82
0
0
Location
Greenville, ILLINOIS
help please... there is an unusual smell coming from up under the dash when accelerating.. doesn't do it at idle. almost smells like things are about to catch fire.. but i've looked over the mess of wire under the dash and can't seem to find anything that has been hot to the touch.

1986 K5 blazer cucv 22k miles.
 
Last edited by a moderator:

patracy

Administrator
Staff member
Administrator
14,316
3,004
113
Location
Buchanan, GA
Have you read the TM's? The CUCV electrical system can be, well challenging. A volt meter is a must.
 

M1031CMT

New member
356
10
0
Location
Ontario
What is getting 30v? Like Patracy said, that is too high.

If it is reading 30v, it "could be" that like your alternators are over-charging the system.

It should read 28v-28.5v max at all times on the 24v part of the system. The other part of the system should be 12v-13.8v.

If it is the alternators, they are likely dumping out more voltage into the system, causing certain things to heat up.

Might not be something under the dash, but in the engine compartment and the smell being blown into the cab.

You will have to pull out the wiring diagrams and your voltmeter to check to track down the voltages.
 

Titanium Soldier

New member
120
1
0
Location
Mojave California
if you feel like doing a lazy check to rule out over voltage, try diconnecting the alts and running it on battery power for a minute see if it still smells, just not to long or you wil kill your bats
 

doghead

4 Star General /Moderator
Staff member
Super Moderator
Steel Soldiers Supporter
26,270
1,122
113
Location
NY
Please add your State to your location information. This is a site requirement.
 

Warthog

Moderator
Super Moderator
Steel Soldiers Supporter
13,795
179
63
Location
OKC, OK
Reposting your question from the Headlight Circuit thread as it is the same issue and belongs here.
----------------------------------------------------------------------------------------------

I've been having problems with a "hot" smell from up under the dash, and even melted a fuse.. the plastic part literally melted off and on to the floor board.. put in a new fuse. problem seemed to go away for a bit... well its back.. the fuse box seems fine to me. all fuses in tight and clean.. glow plug module under dash looks good too, but the harness on the fire wall side from the fuse box looks like its been over heated a time or two.. how would i go about replacing the wire connectors for that "head light harness?" ?

ps.. the "hot" smell gets worse when accelerating.
 

mistaken1

New member
1,467
6
0
Location
Kansas City, KS
If plastic melted something got hot. If you can smell it when using the vehicle something is still getting hot. Poor electrical connections act like the heating element in a toaster.

If you are not carrying a fire extinguisher I recommend you do so until you resolve this problem.
 

hvillem1009

New member
40
0
0
Location
Pelahatchie, MS
I had the same problem before. I had to pull the dash apart and that is when I noticed the wires going to the started relay were burnt bad. My voltmeter did show over charge before the burning smell. I have since replaced start relay with doghead conversion and replaced wires.
 
Status
Not open for further replies.
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks