M61 5 ton fuel pump

Polaris bryan

New member
20
11
3
Location
Hudson fl
Trying to find a suitable fuel pump for this truck. The tanks are shot after I got them cleaned they both look worse than Swiss cheese lol....
That being said I do have a old partially stripped down 5 ton crane truck (I bought for the crane) it has both tanks that are good , however the 5 ton used a pump on engine not in tank as my m61 is. So I can swap tanks they will fit within brackets but need a external type fuel pump... anyone know the rate,psi needed for the engine to operate properly?
There is many out there found a few nice ones rotary type with stainless pre screen and clear bowl that's serviceable ,faucet brand with 3/8 fittings.
 

NDT

Well-known member
Steel Soldiers Supporter
8,978
2,322
113
Location
Camp Wood/LC, TX
Several of the aftermarket retailers have “external fuel pump kits” they have cobbled together for the “deuce” crowd, these will allow you to use the gasoline fuel tanks with your LDS diesel.
 

Polaris bryan

New member
20
11
3
Location
Hudson fl
Several of the aftermarket retailers have “external fuel pump kits” they have cobbled together for the “deuce” crowd, these will allow you to use the gasoline fuel tanks with your LDS diesel.
Would you mind directing me twords those retailers? Or at least a direction on where to look.
 

BEASTMASTER

Active member
864
56
28
Location
Burgaw, N.C.
i've been using an inline pump on my m-61 for 5 yrs now since the one on the block crapped out and i can.t find one. it's mounted right ater the filter on the frame. it's 12 volt wired to a cheap 24 to 12 volt inverter.
 

Polaris bryan

New member
20
11
3
Location
Hudson fl
Ok so been a while , update on the rig. I have swapped out tanks from a 5 ton crane truck. Plumbed it all in using a external pump with 5 to 7 psi. Got all primed new filters new lines and a spin on style fuel filter seperator type.
Fresh batteries all new cables and ends. Been bust lol. Anyhow I have a new issue regarding fuel....
Truck will start while holding accelerator to floor , will very slowly Rev up (little response if any) if I let off the pedal rpm will slowly drop. Response from pedal is very slow. Will not idle on own have to keep playing with throttle.
I'm thinking the IP is gummed up somewhere?? How big of a deal is it to try and clean?
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks