Turn Signal Issue

Corvette1974

Member
493
1
18
Location
Pennington, NJ
Hello,

My truck has developed an interesting issue with the turn signals. All bulbs are fully lit, some are new, and the flasher module is new with a HD mechanical one. The system seems to blink too rapidly - not a hyperflash, but in between the hyperflash and a normal flash. Any thoughts on why this would happen? It happened all of the sudden this week. No recent changes have been made to the truck.

-Will
 

Corvette1974

Member
493
1
18
Location
Pennington, NJ
I thought of grounds, but would that effect the flash speed? I thought that would just change the lights actually working or not? I did find this quote from a good thread - "
Another MAJOR issue with grounds is the metal tab inside the tail/parking lights. It corrodes and ends up breaking off.
"

-Will
 

Drock

New member
1,020
9
0
Location
Eatonton GA
Well couple things come to mind. Are you sure the front side marker lights are flashing? and also I've had the HD flashers be an issue on other cars.
 

Corvette1974

Member
493
1
18
Location
Pennington, NJ
Well couple things come to mind. Are you sure the front side marker lights are flashing? and also I've had the HD flashers be an issue on other cars.
The side markers (two screws) mounted on the fender corners? Yes definitely flashing, new bulbs.
I agree. Put a standard duty flasher in and give it a whirl. Happy Easter.
Ahhh so there could be a general compatibility issue... I'll pull one out of a known good vehicle and try it out.

Happy Easter!
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks