1951 M-37 generator won't polarize

Pete P

New member
3
0
0
Location
Harborcreek, Penna.
Hi.

Working on my uncle's '51 M-37. Gen. won't polarize / won't charge. Cleaned the points on all the relays in the regulator, cleaned up and verified ground contact to regulator. Verified continuity in reg-to-gen cable. Found an open noise suppression capacitor in the armature output circuit in the gen -- removed that and replaced with direct wire to the cannon plug. Brushes and commutator look good.

I'm seeing 24 v from the batteries to the regulator, the reg. is putting 11.5 v or so out to the field but I'm only seeing a puny 5.8 to 6.0 v coming back from the armature. Obviously the cutout relay isn't even close to closing. I've tried repolarizing several times by shorting BAT to FLD (using the terminals in the regulator with the cover removed) both stopped and running and I can't get the gen to flash over, even at about half throttle.

Is a field of 11.5 v normal? I haven't tried to measure the current being drawn by the field but the ARM voltage drops to less than 1 if I open the FLD circuit so it can't be totally open. I hate to tear the gen down and rewind her only to find out it's not the problem. I also don't really want to go with an electronic reg if I can help it.

Thoughts?

Thanks in advance,

Pete P.
Harborcreek, Penna.
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks