37x 12.50R 17 tire upgrade on CUCV

mtperkins

Member
44
23
8
Location
Cazenovia,NY
If your asking me about the power with the 37's... then its fine for what I do. These day's I'm in no hurry to get anywhere. I have a few more little items to fix then get the truck NYSI. The trans is not shifting very well. I hope it's a vacuum leak from sitting around.
 

2INSANE

Well-known member
Steel Soldiers Supporter
660
691
93
Location
Belgrade, Montana
If your asking me about the power with the 37's... then its fine for what I do. These day's I'm in no hurry to get anywhere. I have a few more little items to fix then get the truck NYSI. The trans is not shifting very well. I hope it's a vacuum leak from sitting around.
The only time I had problems with the th400 was when the Vacuum Modulator got fluid in it. Instead of buying a new one every year, I take it off and simply clean it with brakekleen and compressed air. Then I would adjust the screw on the inside of the Vacuum Modulator to give me the desired shifting firmness or softness.

The hole end of the aluminum vacuum pipe going to the modulator sometimes got build up in it as well. A sharp knife or pick can clean that out.

Should be an easy fix for you.
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks