Got my MK30 Today

Steel Soldiers is supported by:

Mustangsud

Member
46
8
8
Location
Aubrey,TX
Really nice truck! Did it take much to get it running?
All it took was batteries. Fired right up. It’s not charging very well, so I suspect it needs another alternator. We just used a 24v power pack and drove it on and off the lowboy. Other than the charging issue, all systems, dump, and winch all seem to be working normally.
 

Elijah95

Member
Steel Soldiers Supporter
587
10
18
Location
Georgia
All it took was batteries. Fired right up. It’s not charging very well, so I suspect it needs another alternator. We just used a 24v power pack and drove it on and off the lowboy. Other than the charging issue, all systems, dump, and winch all seem to be working normally.
Check your belt tension (I’ll link my video, please like and subscribe if it helps you) and also remove the 6 half turn screws on the passenger side of your dash, pull the panel and plug the harness together to give the TIM power, you can run diagnostics on it and see if your alternator is good or not when running. Sweet truck!
https://youtu.be/bcp4W021u0k

Sent from my iPhone using Tapatalk
 

Karl kostman

Active member
Steel Soldiers Supporter
1,902
14
38
Location
Fargo ND
That is one beautiful truck and I would sure like to believe will be my next years purchase!! CONGRATS!
Karl
 

Elijah95

Member
Steel Soldiers Supporter
587
10
18
Location
Georgia
IMG_2835.JPG
Can you do me a huge favor and look behind your transfer case and see where these plugs go? IMG_2835.JPGIMG_2835.JPG
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks