Help on Radius Rod M 998

Steel Soldiers is supported by:

101
1
18
Location
Southwest Virginia
Trying to adjust the left radius rod on my 998. I have loosened up the lock bolts (taken off) and soaked the threads for three nights in my special sauce of acetone and tranny fluid and the thing is still as tight as Dick's Hatband. One differ I noticed is there are no reliefs cut into the threaded portion of the rod. Actually I'm not sure I have ever seen a adjustable rod that didn't have a cut. Anyway I'm wondering if maybe this is the right part or could it be for something else? The tire is off by about 10* in tow and camber. No stretching, it drives like it's on a ball LOL. The other side has the cut in it but is off by about 4*. There is more than enough thread to set it to 0*. Thanks for your help.
 
101
1
18
Location
Southwest Virginia
Is there a difference in lengths? I can see where this is the problem as it seems the hub assemblies differ too. The side the radius rod goes to appears to have no oil fill plug like all the others. I have two 998’s. Still learning every minute.
 

cucvmule

Member
Steel Soldiers Supporter
769
20
18
Location
Crystal City Mo
NDT is right on as a little heat on the adjustment sleeve will break the seizure of the threads. Work it back and forth a little at a time and if one end is open drop out the rust as it will act like glue by getting into the threads.

Good Luck
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks