horn not work after replace cam

Saberr

Active member
Steel Soldiers Supporter
177
75
28
Location
Temecula,Ca
A few weeks back i replace my turn signal cam and switch, all work sort of. Left turn wouldn't cancel. Took apart today and found slight clearence issue, remedied it and now both turn signals cancel. Put back together and now my horn will not work. It works if i ground the horn button to my shift lever or other steel in the cab (so i know its getting connectivity to top of the wheel), but doesn't work if i ground it to the steering shaft, I know this suppose to be where the horn grounds the button, what is wrong ? im very confused now.
 
Last edited:

Saberr

Active member
Steel Soldiers Supporter
177
75
28
Location
Temecula,Ca
OK, solved it. I actualy found the answer though fj forum. The ground is ran through the rag joint into the steering box. That Rag joint is the issue, it has a little tiny piece of metal that connects the inner splines to an outer bolt. That piece brakes. Simply put a jumper wire from one side to the other to connect the ground. Make sure its a small wire. Since the joint is one piece, the wire will not get destroid and clears the fender cleanly. Another symptom of this problem is the horn works intermitiedly or unreliably. Here is a pic of my fix. Can also replace the rag joint.

20200807_171518.jpg
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks