I need some advice on how to go about fixing a MEP 003a

Steel Soldiers is supported by:

maddog

New member
50
0
0
One of my MEP 003a's works fine, the other runs ok but doesnt make any electricity.

I have the manual and I am a capable mechanic and can hold my own with electricity but dont know much about electronics.

Where would I start to figure out what might be wrong with this thing?

Thanks
 

Carl_in_NH

New member
843
1
0
Is there a troubleshooting flow-chart or process in the TM for electrical side failures? I think that's typically included. I think the TM for the MEP-017A has such a step-by-step one can follow for troubleshooting - but I've never looked at the MEP 003 TM.

For things like gensets, one typically doesn't neem much more than the TM, a multi-meter, and a clip lead or two to run through them and at least diagnose the failure to the component or sub-assembly level.

-Carl
 

Speddmon

Blind squirrel rehabiltator
4,678
9
0
did you try flashing the field after you had it running. It's supposed to flash itself when you start it, but sometimes you need to do it again. After it's running, turn the knob to start again, just for a few seconds though, this will flash the field and if everything else is in working order it should start producing power. If that doesn't work, there is a troubleshooting section in the TM like Carl_in_NH mentioned.

First look in TM 5-6115-585-12 on page 3-8 and follow that troubleshooting section. If that doesn't work go to TM 5-6115-585-34 on page 2-10 for the more detailed troubleshooting section.
 

maddog

New member
50
0
0
Thanks guys, I was just over at smokestack reading about flashing. I have the manual but have not yet started the troubleshooting.

Tomorrow, I troubleshoot.:-D
 

maddog

New member
50
0
0
Oh, I see. I printed TM 5-6115-585-12 but not TM 5-6115-585-34 so I will have to do that. Another ink cartrage and half a ream of paper.

Ahhhh, but then I will be prepared for anything.:-D
 

Speddmon

Blind squirrel rehabiltator
4,678
9
0
you do know, that you can just save the TM's to your computer and print only the pages you want to look at, at any given time...right?

Sure saves a lot of ink and trees that way.

while you're at it you might want to get the -24P manual too...it's the parts manual
 

dj1230

New member
1
0
0
I have a mep 003-A. my aux system doesn't work. when I turn master from off to prime/aux, the aux pump runs-then I go to start and while gen is running, I turn back to run/aux and engine dies but pumps stay running. help-- thanks dj
 

storeman

New member
1,347
49
0
The starter switch position you are going to is only for priming the fuel system. Once started, don't turn it back to prime/aux or you will kill the engine. Once it is running, just release the spring loaded position of the starter switch. Your unit is acting as it should.

Welcome BTW.
 
Last edited:
Top