M1008 starter problems

MVtrucker

New member
357
3
0
Location
Bridgeton, NJ
If this was a civilan truck, I'd know where to start looking.
I don't know much about the electrics in a CUCV.
My M1008 is sitting by my garage, broke again. I got in it
yesterday and without thinking (I drive a Chevy Blazer a lot),
I hit the starter before the wait light went out. I quickly left
off and waited for the light to go out and tried to start it.
All it did was pull several lights out on the dash. No click,
no nothing. I really don't know where to start looking for
the problem. I tried anther card, didn't help. I had started
it about an hour before this to move it out of the garage
and did not have any indication of a problem. Batteries
are charged.
Edit: I already tried to research the manual on my CD. Although the Operatores Manual and Parts open, the Maintenance & Repair won't.
 

Desert Rat

New member
2,333
5
0
Joe,
Don't you love it when you fix the problem before anyone can offer advice?!? I do...........
 

MVtrucker

New member
357
3
0
Location
Bridgeton, NJ
I had also posted it to the mil-veh list and got the info I needed within a short time.
Quite a few experienced CUCV owners there. I have a new starter on hand and was going to pull the old one, not knowing there was a relay under the dash. What amazed me was John, the counterman at my local NAPA. The old relay does not have any part numbers on it. John opened up a big catalog and started looking. Found something close to mine, got one off the shelf, compared it side-by-side and told me it should work, but it'll cost me eight bucks to find out. It worked! NAPA #AR135. The mount is slightly different, but still works.
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks