M1010 AUX box heater won’t ignite, looking for help or replacement

Steel Soldiers is supported by:

OktobrVega

Member
93
0
6
Location
Houston, Tx
My heater ran for about 15 mins then stopped on it’s own. I have fuel all the way to the regulator. But seems the regulator does not open allowing fuel to enter the downtube. When I go to START light smoke comes out at first, but it doesn’t ignite. Ive tried everything. Made sure all connections tight. All solder points good. Voltage present. Just at a loss. I’m thinking this unit just may need replacing since I have no idea where to find parts or parts breakdown.

I can’t find the thread where it was mentioned who made these units. Think they mentioned the manual being 100$ something like that. Anyone have that thread saved ?

Also if you have a known working unit get with me on price.
 

Mad Texan

Member
Steel Soldiers Supporter
212
23
18
Location
Chester County, PA
Found the tear down for the model 10530A heater.
It starts from 14-35 to 14-51 (pages 635-651) in the
TM 9-2320-280-34 I wish I could find someone who can service the units.

https://www.nsncenter.com/Files/library/TM/HMMWV/TM-9-2320-280-34/TM-9-2320-280-34.pdf



Here’s the thread mentioned if it helps anyone.

https://www.steelsoldiers.com/showthread.php?147220-Troubleshooting-M1010-fuel-fired-heater
Very good reference information. Had I had it I might have looked into mine further! Instead...
 

Attachments

Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks