M1078 Cab tilt hydraulic

Steel Soldiers is supported by:

FrankTEXSAR

New member
1
0
1
Location
San Antonio, TX
Hi all,

I am having a problem with the cab/tire tilt hydraulic on a M1078.

When I activate the pump, hand pump or electric, the hydraulic fluid comes out at the cab locking pin.
The cab does not move at all.

Any suggestions on how to trouble shoot this the best way?

Thanks,
 

NDT

Well-known member
Steel Soldiers Supporter
7,877
417
83
Location
Camp Wood/LC, TX
Get a 1-3/4 wrench and remove the latch cylinder cap. Pull out the plunger and replace the National #216 O-ring inside.
There is a thread on how to do this.

thread:

 
Last edited:

Ronmar

Active member
605
168
43
Location
Port angeles wa
you have a blown seal(oring) in the cab latch. You can disassemble it and replace the seal, but that latch needs to be sealed in order to send pressure on to the lift cylinder. You can remove and cap the line and manually pull out the pin from the end to tilt the cab, but you should be able to reach the latch for repair OK if you lower the spare tire. you will need a big wrench or socket to unscrew the end to get at the piston/seal...
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks