M35A2 not starting

Steel Soldiers is supported by:

Brew

New member
5
0
0
Location
Indiana
My M35A2 will not start. I’ve got 23v at battery. When I turn on accessory, all gauges work and low air alarm sounds. Hit start and nothing. I changed horn solenoid but didn’t have new horn button to test solenoid. After horn button install, nothing, checked horn and found solenoid burned up. Could I have crossed the wires? I’m at a loss.
 

Evil Dr. Porkchop

Well-known member
Steel Soldiers Supporter
Supporting Vendor
1,884
77
48
Location
Colchester, VT
Your batteries are a bit low to begin with. I would start by charging and load testing your batteries first.
Welcome to the site by the way.
 

SETOYOTA

Well-known member
Steel Soldiers Supporter
2,239
69
48
Location
georgia
Those starter buttons are kind of finicky at times as well. You might try a jumper wire to exclude it.
 

Karl kostman

Well-known member
Steel Soldiers Supporter
1,963
69
48
Location
Fargo ND
As was stated on the first post be sure to load test those batteries, that has been the biggest battery problem I have had over all these years, now if I have a problem and voltage looks OK I load test, saves a LOT of time!
Karl
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks