M51A2 lost power steering

eric67camino

Active member
Steel Soldiers Supporter
149
40
28
Location
Kansas
Ok. I have a 1952 Mack M51A2. Has the LDS-465-1A engine. Steering box on the frame says Hydrapower.

Was driving last week, and was fine for several miles. Went around a roundabout, straightened up, seemed normal. Then noticed that steering was a little sloppy, started noticing that steering felt heavy after taking up the slack in the wheel. Figured I had a tire gone flat, so I pulled over and all were good. Took off again and had no power steering.

Now, I don't remember it having that much slack in the steering before, but can't swear to it. Thought it was pretty tight. Checked steering column and shaft, all seems tight. Looseness is in the steering box. Has about a half turn on the shaft/steering wheel before trying to turn the rest.

Verified there is fluid in the resiviour. About an inch or two down from the cap threads.

Truck is old and has some seeps/leaks, but nothing that appears to be coming from the pump. Hoses look dry. And full of fluid, so assuming not a loss of fluid pressure to the outside issue.

I'm assuming that I have an issue internal to the pump or steering box. Read about the pumps shearing shafts, so that's on the radar. Didn't know if the possible sudden slack in the steering box could be related, or not.

Just looking for suggestions on how to attack this before I get started. Is there a way to adjust the steering box to tighten it up like on some older cars? Would that have anything to fo with the loss of power? Or do you think it's just the pump?

Thanks for any advice.
 

eric67camino

Active member
Steel Soldiers Supporter
149
40
28
Location
Kansas
So I removed and disassembled the power steering pump and found the shaft had sheared in two.

I got a new shaft, bearing, and seals. Got the shaft in the housing, but have a question on the vane gerotor part.

Which direction does the pump turn? In the time between disassembly and parts coming in I have forgotten which direction it goes.

Anybody have any idea?
 

Robo McDuff

In memorial Ron - 73M819
Steel Soldiers Supporter
2,460
240
63
Location
Czech Republic
Not really, I had a problem with the M51A2 steering as well. In the end, I combined two old steering gear boxes to get the stuff back to work.

If you put everything back as was, it should work good automatically. And the usual advice, check what you are doing against the TMS


Mainly the

...20-2 page 313
...35 page 149

and probably some of the others. Sometimes It might help to check the 809 series, many systems are the same, not sure about the hydraulic pump though.
 

eric67camino

Active member
Steel Soldiers Supporter
149
40
28
Location
Kansas
Not really, I had a problem with the M51A2 steering as well. In the end, I combined two old steering gear boxes to get the stuff back to work.

If you put everything back as was, it should work good automatically. And the usual advice, check what you are doing against the TMS


Mainly the

...20-2 page 313
...35 page 149

and probably some of the others. Sometimes It might help to check the 809 series, many systems are the same, not sure about the hydraulic pump though.
Thanks for the suggestions. I'll have to have another look at the manual when I get home. Everything has gone together well, I just want to confirm the vane portion is going in the right direction since it's reversable.
 

eric67camino

Active member
Steel Soldiers Supporter
149
40
28
Location
Kansas
I went through the manuals again. Didn't find anything on the actual assembly/disassembly, just removal/installation.

I didn't have the truck in front of me, so I put it back together the direction I thought it went. When I got it back to the house I had someone bump the starter while I watched the gears turn through the opening. Wouldn't you know it, I have it backwards. I got it swapped around, but ran out of daylight. Hopefully I will be able to finish installing and test tomorrow.
 

eric67camino

Active member
Steel Soldiers Supporter
149
40
28
Location
Kansas
I'm going to have to start completing projects quicker or doing a better job of documenting the process.

Trying to get this radiator back in, but my memory fails me.

Where does the other end of this ground strap go?

Truck is M51A2.

EDIT: Nevermimd. I was able to locate signs of a star washer on the steering pump adapter.
 

Attachments

Last edited:
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks