• Steel Soldiers now has a few new forums, read more about it at: New Munitions Forums!

  • Microsoft MSN, Live, Hotmail, Outlook email users may not be receiving emails. We are working to resolve this issue. Please add support@steelsoldiers.com to your trusted contacts.

MEP 804a

peapvp

Well-known member
Steel Soldiers Supporter
1,033
1,060
113
Location
Basehor, KS
@Captain Ray Paul, I would suggest to wait for @Guyfang until he gets back. I believe that he thought that you may have water inside the K1 contactor.
Guy is probably going to merge this thread with your original thread. I think there are forum rules which prohibit posting the same issue in multiple different threads.
It becomes to complicated to follow and help someone with the same issue when they are spread out over multiple threads.
I did not have experienced this particular issue you are experiencing, so @Guyfang would be the person with the most experience with your problem

Peter
 

Guyfang

Moderator
Staff member
Moderator
16,005
22,437
113
Location
Burgkunstadt, Germany
Peter is correct. The same problem in two or more threads is a no go. I will be merging the threads.

Where are you taking your voltages readings from? The TB1?

But until I do, I would first ensure that the wires are all correctly hooked up, BY THE WIRE DIAGRAM. Normally what I did when I am troubleshooting on such a problem, is unhook all the wires. Look at the wire diagram to re-hook things up. It has happened several times to me, when I was young and dumb, that someone wired something up wrong. Then along came PFC Guy, and unhooked wires, marking them as I did so. Then re-hook the wires up. When you do it this way, you simply repeat someone else's mistake. To be 100% sure, unhook them all. Then re-hook them up. Then and only then can you say you KNOW its right. If you have the same problem after re-hooking them up, plan B. That would be to take out K1. You can test it IAW the -24 TM, on the work bench. I also would take the K1 apart, This device is extremely well known to have water and corrosion in it. That can cause it to Not function right, partially function right or short itself out in side. But first things first, TB1. Check and test.
 
Last edited:
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks