Mep-805a- 30kw generator

Steel Soldiers is supported by:

walkerman

New member
10
0
1
Location
Palm Harbor florida
need help the overspeed and under voltage light stay on and will not run cleaned sensor and still did not work . will a new one help ? do not have part number

anyone in the Clearwater Florida area that works on these need to find someone

Thank you
 

Tinstar

Super Moderator
Super Moderator
3,626
55
48
Location
Edmond, Oklahoma
Welcome to Steel Soldiers

Have you downloaded the Technical Manual?
Did you search the forums for the same issue?
Issue has most likely been covered before.
 

Suprman

Well-known member
Supporting Vendor
6,701
87
48
Location
Stratford/Connecticut
The tms are in the section top of the forum page. There are step by step troubleshooting. If you download them and start troubleshooting, and still get stuck, you can at least post how far you got in the process. Making it easier for someone to offer advice.
 

Zed254

Active member
Steel Soldiers Supporter
696
155
43
Location
S. Hampton Roads, VA
ARMY TM 9-6115-644-10: https://www.steelsoldiers.com/showthread.php?103683-MEP-805a-manuals

Search for overspeed to find location of overspeed reset switch (P39/119). Page 54/119 has "2-8 INITIAL ADJUSTMENTS, DAILY CHECKS
AND SELF TEST" that will show how to set up machine for start up. Page 55/119 has "2-9 OPERATING PROCEDURE." that will show you how to start it up.

And don't forget to drop a ground rod.
 

Guyfang

Well-known member
7,273
1,003
113
Location
Burgkunstadt, Germany
need help the overspeed and under voltage light stay on and will not run cleaned sensor and still did not work . will a new one help ? do not have part number

anyone in the Clearwater Florida area that works on these need to find someone

Thank you
Lets start again. Did this gen set ever work right? Is it new to you? Did you reset the fault indicator?
 

Guyfang

Well-known member
7,273
1,003
113
Location
Burgkunstadt, Germany
Try this. Reset the fault indicator, and hold it in the reset position. Then start the set. Keep the fault indicator in reset position. Then flip up the battle short switch. THEN let the reset go. Still running?
 

walkerman

New member
10
0
1
Location
Palm Harbor florida
Thank You I will try it Monday I'm in Florida looking at the weather. I'm in Clearwater Fl and if anyone knows someone near me that works on these generators I would be happy to pay someone to help.
 

mcii

New member
72
1
0
Location
Wimberley, Texas
also ? DOESN'T THIS SERIES HAVE THE overspeed RESET LOLCATED ON OR WITHIN THE INTERIOR OF THE CONTROL BOX NEXT TO THE 50/60 SELECTOR SWITCH.. DONT THINK JUST PUSHING THE TESTLAMP RESET BUTTON ON THE INDICATOR PANEL ON THE FRONT PANEL WILL ACTUALLY RESET THE OVERSPEED CONDITION.. LET US KNO MAC/MC
 

walkerman

New member
10
0
1
Location
Palm Harbor florida
Thank You I got the generator running most problem were dirty connections. I need to find out how to make this 3 phase generator to
single phase I watched Matt Verley u-tube on doing a mep-oo4A generator I would like to find out if this is the same
Thank You
 

Scoobyshep

Active member
137
70
28
Location
Florida
The 005 is a 12 lead head, so he did a retap to low zigzag. If memory serves the 805 is a 10 lead head and cant be changes the same way.
 

Guyfang

Well-known member
7,273
1,003
113
Location
Burgkunstadt, Germany
Thank You I got the generator running most problem were dirty connections. I need to find out how to make this 3 phase generator to
single phase I watched Matt Verley u-tube on doing a mep-oo4A generator I would like to find out if this is the same
Thank You

Ain't gonna happen. You are talking about apples, (MEP-805A), Matt is talking about pears, (MEP-005A).
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks