MEP15A 1.5 KW carb "issues"

Capt'nChaos

New member
16
0
0
Location
Western Mass.
I picked up a 1.5KW genset for a sweet deal (read $0). It didn't run when I got it but after cleaning the gunk out of the carb it ran like a top for...about a week. Then it started shooting gas out of the air cleaner..I figured the float wasn't closing all the way and just got a new carb from Saturn Surplus.

I installed the new carb and it started on the first pull about a dozen times. Tonight I tried to start it and I found gas running out the air filter again. I'm guessing the float has sunk or there is junk in the float valve seat.

Does anyone have any suggestions to fix this or am I going to have to buy a gross of carbs?
 

Recovry4x4

LLM/Member 785
Super Moderator
Steel Soldiers Supporter
33,950
1,113
113
Location
GA Mountains
I believe I'd have a looksee in the tank. The little cheesy filter screens in the fuel line aren't that great and it might have sucked up some spooge.
 

Capt'nChaos

New member
16
0
0
Location
Western Mass.
Thanks guys. You are pretty much confirming my thoughts on what's happening. After having the same problem with 2 different carbs I'm hoping it's just some spooge and I can flush it without disassembly. I also need to put a filter back in the sediment bowl..I never knew there was suppose to be one in there.

If my float level is off, I'm not sure how it happened....unless the float has sunk. That would make me very unhappy. Does any one make a EFI kit for this engine?
;-)
 

peyton

New member
74
0
0
Location
houston, tx
Re: RE: MEP15A 1.5 KW carb "issues"

rumplecat said:
I'd like to help but I have never had any of mine do that! Sounds like the float is stuck in the low position.
James G.
I agree. My 3kw genset does exactly that. The float absorbs gas and swells enough to stick. Tried a new carb from Saturn, did the same thing. I think the float material is *not* compatible with ethanol laced gas. Tried to seal the float with some gas tank sealer but that didn't work for long either. I'm going to try grinding the float bowl for more clearance. Good luck

Peyton
 

mangus580

New member
6,051
277
0
Location
Western NY
RE: Re: RE: MEP15A 1.5 KW carb "issues"

Now that you mention it, most of the ones I have been in all seem to stick to an extent like that. What a PITA.... esp on the 'wrap & hope' model engines.
 

Capt'nChaos

New member
16
0
0
Location
Western Mass.
RE: Re: RE: MEP15A 1.5 KW carb "issues"

Tried to seal the float with some gas tank sealer but that didn't work for long either. I'm going to try grinding the float bowl for more clearance. Good luck

Would there be any benefit to shaving the float instead of the bowl?
 

mangus580

New member
6,051
277
0
Location
Western NY
Re: RE: Re: RE: MEP15A 1.5 KW carb "issues"

Capt'nChaos said:
Would there be any benefit to shaving the float instead of the bowl?
This might cause you other problems, as the float may not have the strength to close the needle then.
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks