New 3 kw Set

m139h2otruck

Member
570
1
16
Location
NH
New MEP-16 we just got. Was on E-bay in the next town over (Milford). Hate to tell you how much (little). Built in 1969 and rebuilt in 1989 (has CARC on engine per stamp) with an hour meter reading of 80+ hours. Unit runs great and made power at the side plug outlets after I fiddled with the fuses and set the speed up to match 60 Hz. Have to read the TMs (per Ace) to see how to hookup for power at the terminals. These little 4 cylinder engines run very smooth and fairly quite.
 

Attachments

Recovry4x4

LLM/Member 785
Super Moderator
Steel Soldiers Supporter
33,974
1,221
113
Location
GA Mountains
I have one and am quite pleased with it. Do you have the electric start kit for it?
 

m139h2otruck

Member
570
1
16
Location
NH
No, only pull start. Started on the 4th pull after I cleared the cylinders, primed the fuel pump and used just a little "juice". Voltage only shows on the gage when the outside selector switch is in the V1-2 position regardless of the inside switch position. Any tricks to this?
 

m139h2otruck

Member
570
1
16
Location
NH
Started unit last night and reset the gov for better control of the response time and droop. Rechecked voltage at all legs. In 3 phase 120/208 did get the right voltage at the terminals. Just had to read Ace's manuals! Really impressed with how smooth @ 3600 rpm the unit is. Should be easy to install silencer pads/boards to limit noise, just a little thirsty @ 0.95 gallons/hour for long time use.
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks