Turn signal problem

Steel Soldiers is supported by:

GeoffH

New member
8
0
0
Location
Exeter UK
Hello to you all,
I have not long had an M35A2 which bought when i sold my jeep as i was finding it very hard to get in and out of it but the REO is so easy for me. Now here in England just having only the red lights at the back of the vehicle is not a good idea
so i purchased a couple of new indicators the same ones as fitted to the front i made up some brackets and mounted them alongside the rear ones
so far so good. now on the driver side i put the signal on and unplugged the wire that set the red one going and connected it to my new amber one .and it worked the side light is good and the brake.
now on doing the same to the other side it will not work i unplugged the red turn wire connected to the new and it works but now the fun started when i turn the side lights on the amber turn lamp won't work but the red light flashes .here is the part that has me baffled when i have the side lights on and run a separate wire from the original turn feed plug to the new lamp it does not work but strangely the red one comes on and flashes .now i cannot begin to wonder how that can happen as the lamps are not connected together apart from being attached to the one bracket.
I would appreciate any help with this .

The reason the body is slightly high as it has been converted to a home from home camper with beds cooker fridge etc and is very cosy for weekends away at shows
reo rhs.jpg
 

porkysplace

Well-known member
Steel Soldiers Supporter
9,141
259
83
Location
mid- michigan
You need to tap into the front turn signal wire on each side and run the wire to the rear. The rear turn signal and the brake light use the same wire at the rear , this is wear your problem most likely is.

Post #2 of this thread has a wiring diagram for the M35A2;
Peter Bog's CAD deuce schematic!

Edit ; Welcome to SS

Not sure where in the UK you are but member dmetalmiki is in London and a wealth of knowledge on these trucks.
 
Last edited:

GeoffH

New member
8
0
0
Location
Exeter UK
Thank you for reply ,that would make sense i will do just that when i get some wire and report the outcome on here.

I have just had a tech manual delivered from your side of the pond and i had wondered that on the wiring diagram i could not find rear turn signal wire number
only the front.

I am in Devon London is about 200 mile away .

And thank you for the welcome i am sure that i will be asking for help now and then

Cheers and take care

Geoff
 

dmetalmiki

Well-known member
Steel Soldiers Supporter
4,746
136
63
Location
London England
Welcome to the site, The hobby, And the friendships and Events to come.
We 'WILL' see you at War and Peace next year?
If you need additional help, just give me a bell. (P.M. me for my number).
As said by porkysplace, " you ARE (actually (trying)) to wire up the brake lights"....Bell me if stuck.
 
Last edited:

GeoffH

New member
8
0
0
Location
Exeter UK
Thank you for the help i will have a look at the turn signal switch along with a lot of other wiring
oddities that i have found when i managed to get underneath.

I will PM you dmetalmiki thank you i would have to save my pennies for a trip to W&P
at best part of a 500 mile round trip the fuel bill is scary.

Cheers
 

dmetalmiki

Well-known member
Steel Soldiers Supporter
4,746
136
63
Location
London England
I sent my phone number to you, yours seems always turned off, (And) There is always "War in the Vale", perhaps nearer to you?.
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks