Vic-1 troubleshooting assistance needed

Steel Soldiers is supported by:

patracy

Administrator
Staff member
Administrator
Steel Soldiers Supporter
13,727
896
113
Location
Buchanan, GA
So I'm trying to get a intercom system going in my Ferret using a vic-1 setup. I get nothing out of it.

I have the power coming into J508 on the AM-1780

I've got cx-4723 cables to two c-2298s.

The two control boxes have bailout cords attached with the yellow band to the left plug for intercom. (J803) and the unbanned cord to the right radio plug (j802).

The bailout cables are plugged into tanker headsets.

I've made sure the mic plugs are seated well in the headsets too.

The cx-4723 are NOS.

I've tried swapping in other c-2298s I have.

I've tried moving the ports on the am-1780.

I've even swapped am-1780s.

Swapped one spare bailout cable I have.

The only things I've not swapped are the headsets. (Don't have any to swap)

Both units power up. I've got power set to intercom only. Installation switch is set to int only.

I've played with int accent and radio trans with no change. I've set the stations to all, int only, but neither seem to change a thing.

I have noticed that one am-1780 has a high pitched whine that I can hear in the headsets when the stations are set to all or radio b with the volume turned up high.

Oh headsets are mk-1697/g.

Do I have two bad am-1780? Anyone around the Atlanta area have a vic system that would mind testing my parts to figure out what is working?



Sent from my SM-G965U using Tapatalk
 
Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website like our supporting vendors. Their ads help keep Steel Soldiers going. Please consider disabling your ad blockers for the site. Thanks!

I've Disabled AdBlock
No Thanks